MDEK1001 - how to set device FW1 or FW2

I am having problems getting the MDEK1001 kit working. I installed the app onto my android phone, powered up 5x MDEK units (4x anchor + 1xtag), and added them all to a network. I then checked their firmware versions, and updated them to the latest available in the app. However, the system is not working because two of the anchors are using FW1, and the other two are using FW2!. This causes the FW1 anchors to be assigned seat number 0, while the FW2 ones get seat number -1. I tried powering off and on the devices, but they reboot back to the same FW setting.

There doesn’t seem to be an option in the app to control whether a device uses FW1 or FW2.

How can I fix this?

Have you set one of the anchors as an initiator?
Also is UWB firmware update enabled on all the units. You can use the App to set these.

Hi Charlie,

I think there is a bit of confusion, FW1/FW2 is just firmware segmentation, but overall, devices are using both FW1 and FW2.

Can you send the output of stat (when plugging them to usb and connecting to UART using shell mode) for a connected and unconnected device ?


I tried turning on “UWB firmware update” on all devices, it didn’t change anything. All devices already report the latest version of both FW1 and FW2.

I understand the firmware is segmented, what does it mean in the app “Operating firmware”? For some devices it lists FW1, for others FW2.

I tried plugging in the device to my computer, it shows up as “/dev/ttyACM1”. But I wasn’t able to interact with it. I set the baud rate to 115200, then tried “screen /dev/ttyACM1” but nothing happens.


I am experiencing the same issue as @charliehorse where the seat numbers are not incrementing as expected. Would anyone happen to know whether there is a solution to this?