Issue to connect to DWM1001 Jlink UART Shell through virtual box

[color=#000000][size=small][font=Calibri]Steps:[/font][/size][/color]
[color=#000000][size=small][font=Calibri]follow the step from page 21 to page 24 in guide DWM1001_Firmware_User_Guide.pdf[/font][/size][/color]
[color=#000000][size=small][font=Calibri]1) run the DWM1001 into debug mode and in continue running mode.[/font][/size][/color]
[color=#000000][size=small][font=Calibri]2) with J14 and J15 remain soldered to connect the TXD and RXD to JLINK[/font][/size][/color]
[color=#000000][size=small][font=Calibri]3) open Ubuntu terminal and run command minicom -D /dev/ttyACM0[/font][/size][/color]
[color=#000000][size=small][font=Calibri]4) From the terminal, Welcome to minicom” message will show on the terminal. Now hit “Enter” key twice within one second.[/font][/size][/color]
[color=#000000][size=small][font=Calibri] [/font][/size][/color]
[color=#000000][size=small][font=Calibri]Result: “dwm>” didn’t appear.[/font][/size][/color]
[color=#000000][size=small][font=Calibri] [/font][/size][/color]
[color=#000000][size=small][font=Calibri]Please help provide solution to ensure dwm> appear[/font][/size][/color]

Have you verified the terminal setup with a factory programmed unit? It should behave the same with a 115200-8-n-1-none setup.

Hi Steven,

Pages 21 to 24 of the user manual actually covers several different ways to access to chip through UART:

[list]
[]Connection through usb and Virtual com port
[
]Connection through J10 external pins
[*]Connection using a host board such as a raspberry pie 3
[/list]
Can you give a bit more details about which connection you are trying to achieve ?

I’ve tried the following to connect through USB and VCOM and it worked well for me :

[code]// Connect board to computer, in virtual box, go to device -> USB -> check segger link (see page 17 of user manual)
dw@dw: pwd // Print work directory, must be in dwm-simple

/xyz/dwm/examples/dwm-simple
dw@dw: make recover // Loading factory firmware on the device


wrote 3876 bytes from file …/…//recovery/bootloader_s132.bin
shutdown command invoked
// Unable/Enable device in Ubuntu to re-initialize it (repeat page 17 of user manual)
dw@dw: minicom -D /dev/ttyACM0 // if device busy keep calling minicom until it connects, once connect press enter twice. As Ken mentionned, if not working
// use minicom -s, and verify baud rate is set to 115200

[/code]

Yves

Yes. I resolve the issue, my Ubuntu setup for the COM was wrong (9600-8-n-1) and I missing the double enter sequence. By changing my COM back to 11520-8-n-1 and with double enter it works! Thx!
[hr]

Thx! I managed to get it works as well! Appreciate your confirmation too.

In case it helps:
I have had the same problem, I could not make the shell mode prompt to appear when pressing enter two times just after loading the firmware.
But I realized that I could make it work if I disconnected the USB cable and re-connected it. So I tried pressing the reset button (SW1) on the DWM1001-Dev board and it made it work. In other words: after flashing a new version of the firmware, just remember to press the reset button before trying to enter shell mode.