Graph display error

When the grid is switched on tick in phase is removed. I don’t know is this is intended behaviour.

Test1.qsch (2.4 KB)

Best regards

@ivan1,

I tried your sim. I don’t see any issue.

Magnitude and phase is present for V(n01).

Len

Here, in case 1 normal display, then in case 2 part of the line is removed.

Best regards

@ivan1,

Maybe I understand your issue.

Let me explain my understanding.

You run the sim.

You get a plot of V(N01). It provides two plotted values. Magnitude and Phase angle.

The plot automatically comes with the “Grid” off.

You select the “Show Grid” option and only ONE axis (The Magnitude) has the grid aligned to.
The Phase axis (on the right side) is NOT aligned to the grid.

The issue here is that QSpice’s plotting option only provides one grid per plot window. The default is the Magnitude axis.

The are a couple of ‘tricks’ you can use to improve the displayed plot.

Trick #1:
Right-click select the Phase Axis.
This dialog shows up.
image

Next select the tick: field and set it to 10. Then select “OK”.

You will notice the the phase Axis has different values shown in the axis and they are aligned to the grid as well as the Magnitude.

Trick #2:
Double click on the V(N01) signal shown on the plot. It will display values at a cursor.

You can then move the cursor to the point of interest on the signal. It will display the Magnitude and Phase values at the point of the cursor.

Len

Problem is only that there is break in axis line, everything else is ok. I don’t need phase and magnitude to be aligned.

Best regards

@ivan1 ,

Sorry. I guess I don’t understand: "Problem is only that there is break in axis line … "

I don’t see a break in my axis line.

Len


Best regards

Looks like QSpice is aligning the text on the right end and, when it becomes long enough, it overwrites the right-side of the graph border.

–robert