Getting error while compiling "dwm_timer" application

Hello Everyone,

I am trying to run the sample programs given as examples with dwm1001. I successfully ran the “dwm-simple” program. It worked fine. However, when I try to run “dwm-timer” application it shows the following two errors.

  1. “nrf_drv_timer.h: No such file or directory”
  2. “nordic_common.h: No such file or directory”

Could anyone please help me to resolve the problem? I found that the path of those files are included (using segger embedded studio, select Options–>Preprocessor–>User Include Directories )

Thanks in advance.

Hi auvi,

I guess that the include path does not represent the actual path of files on your pc, so you may have to update it.


Thanks Yves, I have solved the problem

Hi Yves

I want to implement a simple c program to print the location of a tag by considering a simple topology with only one anchor and one tag. If I configure the tag and anchor using the programming codes that are written in the sample program given in (dam-api-test, dam-range-iot) then will that be enough to get the location of tag and print it? Could you please suggest me some sample program links of communicating anchor and tag to play with it?