DWM1001-Dev Segger build issue

Hi all,

I am having some issues compiling anything with Segger and have had a read around and seen a few fixes but still no joy. I am using Mac OSX and seem to be stumbling with the build. I have correctly mapped the toolchain and suspect that it is something to do with the ‘link command’ I have seen raised in other queries but cannot see anything obvious to amend. Any help would be greatly appreciated!

I suspect it is a small amendment required here:

What’s the error you see on SEGGER output window? and which example you are trying to build?

I just get ‘build failed’ no specific error. The output file directory gets built but nothing written to it.

Rebuilding ‘ss_twr_init’ from solution ‘ss_twr_init’ in configuration ‘nrf52832_xxaa’
1> Assembling ‘thumb_crt0.s’
2> Assembling ‘ses_nrf52_startup.s’
Build failed

If you are rebuilding ss_twr_init solution from GitHub - Decawave/dwm1001-examples: Simple C examples for Decawave DWM1001 hardware then ensure these files are present.

  • thumb_crt0.s - dwm1001-examples/examples/ss_twr_init/SES/RTE
  • ses_nrf52_startup.s - dwm1001-examples/nRF5_SDK_14.2.0/components/toolchain/ses

Set Build Quietly as No to see detailed compilation process.

side-note: ensure SEGGER application has sufficient privileges to access mac OS filesystem under security and privacy option.

I amended to allow it full disk access but unfortunately still no change.


Ok, I tried compiling the source from a fresh clone, and I’m able to compile ‘ss_twr_init’ without any errors.

note:- We must change fn prototype of int __putchar(int ch, FILE * p_file) on file retarget.c to int __putchar(int ch, __printf_tag_ptr p_file) to match SEGGER update see - https://devzone.nordicsemi.com/f/nordic-q-a/34784/conflicting-types-for-_putchar?ReplySortBy=CreatedDate&ReplySortOrder=Descending

My setup information

Screenshot 2020-12-15 at 7.47.21 PM

Compilation log when Build Quietly option set to NO compilation.log (345.9 KB)

Hari thanks for all of your help. I’m still not entirely sure on the fix I started a completely fresh install of everything from scratch and it built first time :smile: