DRTLS DWM1001 Gateway stop working

I didn’t understand. Do you think the kernel was updateded automatically? Because that changed the behavior?

If yes. How to prevent this?

As soon as I arrive at the office I will try a fresh image to verify if it works.



Not automatically but maybe more by inadvertance. Let’s see if the fresh image fix the issue. In that case I suspect the kernel was updated but it could be something else as well.

Hi @Yves_Bernard

I flashed a new SD Card, configured it to access the WiFi network, used a new Raspberry Pi, tried another DWM1001-DEV board as gateway, reflashed all DWM1001-DEV boards (Initiator and Anchors).

But the problem continue

Is there another other test to find out what is happen?


Did you change the PAN ID of the dwm1001-dev used in the Raspberry ? I had that problem so maybe you dont have all the nodes (dwm in Gateway, Anchor and Tags) in the same PAN ID.

nis 0x1234 : setup the node PAN ID to 0x1234

Hi @FrancoCapraroArg

Yes, all boards have the same PAN ID. The weird is that everything was working fine. Something happened that stop to work.


Hi All,

A thing a noticed about Bridge leds:

In that experiment, the Bridge is sourced through RBPi only. When I connected the DWM1001-DEV board to computer, I noticed the green led is on, and much more bright. When the board is connected to RBPi, the leds are blinking and the light is very weak.

Unfortunately I didn’t notice the leds when it was working fine.

So, I tried to source the RBPi and Board. The led become on, very bright but the problem continue. :frowning:

Hey guys,

I found out the problem. It was a stupid mistake. I connected DWM1001-Dev incorrectly. Instead align the connectors “on top” I aligned “on bottom”. Probably because of that the led’s brightness was so weak.

But, now the problem is that it’s not possible find the anchors. (They are turned on, with green led on and bright, and I really didn’t change them :slight_smile: )

The system detects the tags, but not the anchors.

Is it possible that happened some damage on the board due wrong connect?

The only test to do is try another DWM1001-Dev board, but I don’t have another 2x13 header with me right now.


Hi Programonauta.
I just started working with this system so I am completely new to the subject. I will give you my 10 cents though, because I noticed something strange. The pictures you posted of the GUI show 3 gateways. I have no idea why that is but o.k. In your first setup the three gateways all had the same IP address. So I guess they are on the same board behind a shared entrypoint? But in your latest post I observed that the purple one is on a completely different address. So maybe that’s why? Second thing I wondered was if you have made sure that all the prints have the same firmware, and have been given the proper role (gateway, anchor, tag)? Good luck!
Greetz, S.

1 Like

Hi @Sapec

I don’t know why the three gateways. I guess is in the my configuration I send the MQTT messages to an external MQTT server.

About different IPs: I changed the networks trying to find out the problem and I suppose the information remained in the cache (?!?!?!).

But the real problem was the wrong connection Board x Raspberry Pi.

After I found my mistake the system detected the Tags but not the anchors.

Unfortunately I will be out of the office until next week, to test others fresh boards. And verify if I damaged some board with the wrong connection.

All the best


Hi Ricardo,

One of the issue on your screenshot is that you have multiples proxy.

In theory a network should have only one proxy, so I suspect something is wrong within your gateway configuration files.

For recollection, only the dwm1001.config file must be modified on gateway. The dwm1001-proxy.config file does not need to be altered.

The gateway for which the dwm1001.config file is not modified (pproxy_server_host = localhost) will appear on the web manager as proxy, as well as as gateway.

For the other gateway, the proxy_server_host should be set to the ip address of the previous device. They will only appear as gateway on the web manager.

The board may have been damaged, so better use other boards to be on the safe side.


1 Like


When I come back to the office I’ll verify all these points.

Thank you so much


Hi Ricardo,

it looks like you have multiple Raspberry running there? If so it looks like your DWM Daemon and Proxy settings are not correct. You can have multiple Daemons but you should have only one Proxy.

See this post for more information on the data chain of the Gateway:

It is completely fine to have multiple Raspberry / Gateway, but they must be configured correctly as follow:

  1. You should choose one DWM Proxy on one of the Raspberry to be used. All DWM Daemons on all Raspberries / Gateways should point to the selected DWM Proxy and to the same MQTT Broker. The MQTT Broker can be either on the selected Raspberry or on Cloud. See /etc/dwm1001/dwm1001.config
  2. One DWM Proxy should be pointed to the MQTT Broker which you are going to use. The other DWM Proxy just leave them default, i.e. they will be pointed to its localhost MQTT Broker, which is unused.

If you suspect the module might be broken then check output of the dmesg command. It should not contain SPI errors.

I hope this would help.


@Yves_Bernard and @leapslabs

Only today I came back to the office.

I tested the system with new board and everything worked fine. I tried with the board that was with problem and… worked fine as well. (Tech mysteries :thinking:)

About the Proxies that appeared on the screen, they continue there. Could be some cache? For instance, when I changed the Raspberry + DWM1001 set, the old ID continue appearing.


Hi Ricardo,

regarding the Proxies - if MQTT worked correctly then on disconnection of the Proxy it should have disappeared from the list. The strange thing is the IP address of the Proxy PROXYB827EB5F92D6 comes from a different network.

Do you have there any VPN network or such there? Can it be that you have multiple remote networks pointing to the same MQTT Broker?


Hi @leapslabs

The different IP addresses are from different networks I used to test. But I tested in different moments, not at same time. It looks like the old network remains in a “cache”.

No, no VPN network.

A clue could be that I use the browser Brave, I will test with Chrome and Firefox to see if the behavior is the same.



A very strange thing that continue happens: it looks like the gateway keep some old values.

You can notice the current IP address of Raspberry does not appear on the gateways list.

The same occur with anchors. I used 4 new anchors, and appear on my screen the old 4 anchors.

I’m using browser Google Chrome

Hi Ricardo,

it has been a while. Could you find the reason why the issue happen at your site?
I cannot think of why that happens. If you subscribe to the MQTT Broker, could you receive the same bridge and anchor topics?

Thanks, TDK

1 Like

Hi @leapslabs,

Yes, sorry for don’t update the thread.

We connected to another MQTT server, and it was sending back the topics, because of that it looks like a “cache”. We turned off the messages and everything worked fine.

Hi Ricardo,

Ok, great to hear it works fine now!


1 Like

Hi, I have the same problem, one of the gateways disappeared probably after sudo apt-get
What can i do to make it appear again without going back to the basic image? thanks