connecting listener to Raspberry using UART Shell mode

Hello all,

i have a system of 4 anchors, 1 tag, and 1 listener.
By connecting the listener to my mac using (minicom -D /dev/tty.usbmodem14411) i am able to enter the shell mode and receive location events.

Now im trying to do the same with my Raspberry Pi 3.
i connected the listener to the USB port as shown in the attached pic, and used this guide to configure the UART port ( I ended up doing the following steps:

  1. Edit /boot/config.txt to add the following lines at the bottom :

    enable GPIO serial port

  2. Disabling the console using the following commands: ( also tried without disabling the console)
    sudo systemctl stop serial-getty@ttyS0.service
    sudo systemctl disable serial-getty@ttyS0.service
  3. reboot the Raspberry Pi.
  4. use “minicom -D /dev/ttyS0 -b 115200” to connect to the port.

but miniport was not able to connect to the listener.
Is this the proper way to connect the listener to a Raspberry Pi and via USB cable and use UART shell mode?
or does it have to be over the pins ?

i found the answer shortly after posting this. i’ll leave the post here with the answer to help any other lost souls like myself that happen to face this issue.

the answer is simply to use (minicom -D /dev/ttyACM*).
connect the listener and list the available ports using :
ls -l /dev/ttyACM*
There you’ll find your actual port name.