Can't select currents in FETs

While probing my simulations, I can click on a wire to get the voltage. If I hover near a terminal on a transistor (Q), the displayed reading turns from a voltage to a current measurement. This does not happen when I approach an NMOS device, showing only the voltage until it turns into a selection of the whole part (all 3 terminals with red dots). Is there a way to select the current flowing in a terminal of a FET?

Ive noticed this also.
Normally Id, Is and Ig are available at the dots but only Ig remains now for me.
It used to work a coupleof versions back.

/Jonas

I thought it used to work, but I had no easy way to test old versions (or my memory). Is this something that I should report to Mike Engelhardt, or does he monitor all this user activity?

I think the preferred way is to mail him directly.

I tested several previous and latest version, but cannot replicate your problem.
When hover over Gate, Drain and Source, all can change to a dot. The cursor must on top of net, any chance you point slightly lower than that and become selection of device?

Two alternative ways

  • In waveform viewer, right click, Add Plot (Ctrl-A) and select current you like
  • use .plot command, e.g. .plot Id(M1) [but you must firstly close waveform viewer before run the simulation for .plot command to work]

I tried it again and it is working for me (just like you say and as I remembered). Unless this just got fixed in today’s update, I’ll just have to chalk it up to random perversity or some strange mode I enabled.

Thanks,
Carl

1 Like

I think it got fixed because it works for me as well now after latest update.

I’d like to believe that it was really broken and got fixed (instead of my incompetent mouse techniques). If I had more time, I’d see if there was some sort of change log to browse, but I need to research details on measuring transformers to aid in simulating hysteresis.
Thanks,
Carl