Cannot recover the dwm1001-dev board

I was trying to program the dwm1001-dev board using Virtualbox & dwm1001_virtualbox_image. I followed the instruction on firmware user guide, everything went smoothly but at the end when I tried the " make recover" command on the connected dwm1001-dev board, it failed. see the attached error message. Switched to the other board, the same setup and command did work well. So something wrong with my original board, my question is how can I recover the board.

[color=#333333]Any help appreciated.[/color]

The board can be recovered doing a full erase and reprogram with the default HEX file supplied with the download packages.
You will need J-Flash Lite too to do this.

Hi Kenneth,

Thank you for your quick reply. I tried the module on J-link lit but it shows “ERROR: Could not connect to target board”. connect to the other board works fine.
what else can I try? Thanks for any help.


Very strange, is the problematic board J-Link enumerating on your PC? Can you confirm that.