Bad RX_TIME during Ranging with sleep


I hope someone more experienced will help me! I have successfuly tested two units with DWM1000 modules for ranging experiment and now I try to minimize the current consumption. When I switch between 500 ms idle state and measurement, everything goes well. But when I replace the idle state with the sleep state, then after SPI WakeUP I have a problem. I send the pool packet from TAG, I receive the Acknowledge packet from CENTRAL, but after receiving I have null RX_TIME. What can cause this behaviour? The reading of SYS_STATUS after IRQ is 0x0F 0x01 0x6B 0x04 0x00 0x00. Is it correct that I have the RXRFTO flag? In β€œidle” variant I do not have the this flag :frowning:

THX, Mard

β€œ6B” … means that there is no LDE done. Please have a look at dwt_initialise, you need to set DWT_LOADUCODE, and then use dwt_configuresleep to configure device for DEEPSLEEP. If LDE/UCODE was loaded when device was initialised, then AON_WCFG_ONW_LLDE should be set in AON_ID register when going to sleep, thus the LDE will be automatically loaded on wakeup.

1 Like

Dear zoran,

you are king of devils! Thank you very much for exact help!
I seted the ONW_LLD0 bit instead the correct ONW_LLDE! Now the module nicely sleep!